Ticket 714: Update postgres jdbc version to support prepareThreshold jenkins-BaltradDex-585
authorAnders Henja <anders@henjab.se>
Mon, 15 Jan 2018 20:48:44 +0000 (21:48 +0100)
committerAnders Henja <anders@henjab.se>
Mon, 15 Jan 2018 20:48:44 +0000 (21:48 +0100)
build.xml
etc/db.properties
etc/testdb.properties
lib/postgresql-42.1.4.jre6.jar [new file with mode: 0644]
lib/postgresql-8.4-701.jdbc4.jar [deleted file]

index 1f726b9..52444b5 100644 (file)
--- a/build.xml
+++ b/build.xml
@@ -230,7 +230,7 @@ along with the BaltradDex software.  If not, see http://www.gnu.org/licenses.
         <include name="*.jar"/>
       </fileset>
       <fileset dir="lib">
-        <include name="postgresql-8.4-701.jdbc4.jar"/> 
+        <include name="postgresql-42.1.4.jre6.jar"/> 
         <include name="apache-mime4j-0.6.jar"/>
       </fileset>
       <!-- Also, include neccesary libs from beast-lib -->
index c2ca10e..d7b776f 100755 (executable)
@@ -1,5 +1,5 @@
 # Database access configuration
-db.jar=postgresql-8.4-701.jdbc4.jar
+db.jar=postgresql-42.1.4.jre6.jar
 db.driver=org.postgresql.Driver
 db.url=jdbc:postgresql://localhost:5432/baltrad_test
 db.user=baltrad
index a47d9ff..40c3a29 100644 (file)
@@ -1,5 +1,5 @@
 # Test database configuration
-itest.bdb.jar=postgresql-8.4-701.jdbc4.jar
+itest.bdb.jar=postgresql-42.1.4.jre6.jar
 itest.bdb.driver=org.postgresql.Driver
 itest.bdb.uri=jdbc:postgresql://localhost:5432/baltrad_test
 itest.bdb.user=baltrad
diff --git a/lib/postgresql-42.1.4.jre6.jar b/lib/postgresql-42.1.4.jre6.jar
new file mode 100644 (file)
index 0000000..fa614e7
Binary files /dev/null and b/lib/postgresql-42.1.4.jre6.jar differ
diff --git a/lib/postgresql-8.4-701.jdbc4.jar b/lib/postgresql-8.4-701.jdbc4.jar
deleted file mode 100644 (file)
index e21beec..0000000
Binary files a/lib/postgresql-8.4-701.jdbc4.jar and /dev/null differ